Widget opens automatically even when configured not too


Hi our widget behavior opens automatically as soon as you open the page. The behavior settings are all unchecked. Tried checking and unchecking and publishing but the behavior is the same. please help
here is the dev page for example. we use the script provided in the Add to Website panel.




Hi Tony,

I tested the above link in Incognito mode. Here is a recording of the same: https://www.mevue.com/v/conmpd161047

At 0:03 I reload the website and 10 seconds later the chatbot pops just fine. In your chatbot, I currently see that you have set open after 10 seconds as the trigger.

Please check the website in Incognito mode as a fresh user.

Aslam from Collect.chat


Hi Aslam
Thanks for getting back to me. So the behavior we were expecting and understood was that the questions/ intro widget would not popup automatically just the icon would appear. So from your video the questions popup almost immediately not after 10 seconds. I’ve unchecked the 10 seconds so it shouldn’t pop up at all unless the user selects the icon. Is this thinking correct? Ive tested this behavior in many sessions and browsers incognito and even after clearing the site cache. It still shows the questions in open mode on page load.

Anyways I’ve disabled the chat altogether as we cant have it open like that on page load.
Anything else that we can check.



Hi Tony,

There are 2 features being used in your chatbot.

  1. Welcome message: The first message of your chatbot becomes the welcome message of the chatbot. In your case it’s the muliple choice with all the questions.

  2. The timer: A setting to open the modal box containing all the questions including the first message.

Here, I believe you are referring to the welcome message. You can either turn it OFF. Or add another message as the first question, like “Hi there”. If you do so, the first message seen by customer will be “Hi there” and when they click on it, the modal box will open and ask the rest of the questions.

I hope this resolves your issue,