Issue with Chatbot Timer

bug-report

#1

Hi Collect.Chat Team,

I use the WordPress Website & Strattic as what hosting service. The chatbot is implemented on one of our web pages with the widget mode. I set a 20% scrolling delay for the chatbot in behavior settings, and it doesn’t work. The chatbot still pops up instantly. Could you please fix this problem for me?

Our webpage: https://www.hemocue.us/
Chatbot ID: 5e65b317260b17379db38a44

Another workaround is that if you know the scroll delayed script that we can add to the existing code snippet directly, please provide the template.

Thank you


#2

Hi Sherry,

I could not see chatbot installed in https://www.hemocue.us/

These could be the cause of the issue you were facing:

  1. Auto-open on scroll will stop after the user clicks the close button on the chat widget. This is to prevent frustration, that is opening the window even if they chose to close chat. You can enter from a new browser or incognito window to test if auto-open works for new users.

  2. 20% scroll is too low and it may look like chat pop-ups instantly in pages with less scroll.

  3. You may have enabled other open triggers like after x seconds or always open in our javascript API.

Please check if any of these are applicable to you.

Cheers,
Shyjal