Help setting webhook


#1

Hello,

I am still trying to send datas to my client, via my ChatBots.

My client gave me a URL with my personnal key, I created a webhook and I input this url+key in the field “Webhook URL”, as you can see here : https://www.screencast.com/t/1QnlfH6RpYf.

Then I input all field keys as described in the webservice.

Then I click on “send a test signal”, I get a notifications saying that the test signal was sent, but I don’t get anything in return.

I did a test, but no datas were entered i my client’s server.

I have correctly maped the Webhook, the destination URL is correct, so what did I miss ?

Thanks in advanced.


#2

Hey,

I just checked webhook inside your account and saw an extra space after ‘lead_type’. Headers cannot have leading or trailing space. Can you please remove the space and try again?

We just updated our product so that this won’t happen in first place. We restrict adding of leading and trailing spaces in webhook keys now.

Let me know if this solution works for you.

Cheers,
Shyjal


#3

Hi Shyjal,

Sorry for late answer, my connection was off all day.

Unfortunatly it still doesn’t work :roll_eyes:.

I have cleared all spaces, I have tries from my back end and from my website, but still no datas are entering to the receiver. I have re-check the destination URL, it’s fine.

So I was wondering if the trouble was comming from one of the folowing.

1- There are 2 “end of conversation” field in this Bot (on my account it’s Test Webhook Bot) . All fields with a key are located after the 1st end of concersation, so that datas should be sent when the user arrives at the 2nd “end of converstion”. Could the fact that there are 2 “end of conversation” in this bot prevent sending the datas ?

2- I use CloudFlare, I saw here https://help.collect.chat/article/show/97849-add-to-cloudflare that there is a way to install Collect.Chat on CloudFlare. However, this will oblige me to install the same ChatBot on all pages. This is not good, as I have a specific chatbot (3 in total) for each category. Do I have to pass by CloudFlare to send datas via webhook ?

Thanks in advanced.


#4

Hi,

Can you try sending data to https://webhook.site/ and check if is working. This can figure our weather the issue is with Collect.chat or with the webhook you are trying to send data.

  1. End of the conversation simply means it ends the conversation and doesn’t move forward. The bot will stop asking questions and 2nd end will never be reached.

  2. Cloudflare app currently has the limitation of one bot per website. You may have to use our Wordpress plugin or add bots via editing HTML if you want different bots on different pages. I didn’t get what you meant by ‘Pass by Cloudflare’. Could you explain that part?

Regards,
Shyjal


#5

@shyjal,

I appreciate your quick response, but you need to be more specific. I am not a technician, just a DIY, and I simply can’t get a freelancer technician for a reasonable price.

It would be really helpfull if Collect.Chat had a set up service, paid service, for these webhook things.

1- So, I followed your link, and I had this URL : https://www.screencast.com/t/GqMns7oviz.

2- I copied it and pasted it as such https://www.screencast.com/t/srwywJKBZyM0.

3- Then I tested the bot directly from my Dashboard, and after end of conversation, this is what I got : https://www.screencast.com/t/AwQTY3v5Eg. What does it say ?

I already have Collect.Chat plugin, it works fats and it’s definitely reliable.
About “pass by CloudFlare”, I was wondering if the datas sent from the bots have to pass by CloudFlare first in order to be delivered to the receiver ?

I have openned a ticket here : https://community.cloudflare.com/t/how-to-send-webhook-with-cloudflare/172587, but no viable answer so far…

I saw this service : https://leadsbridge.com/documentation/collect-chat/webhook/ wich creates a bridge between Collect.Chat and Webhook, would that work better ?


#6

Problem solved, datas are now entering the receiver’s server :wink:.


#7

Sorry for the late reply.

What was the issue? How did you solve it?


#8

It was the the value sent to the receiver.

For example, at the question “Are you a smoker ?” I had set answers as “Unfortunately yes” or “Surely not”, where the receiver’s webservice expected a “yes” or “no”.

It could be a good idea to add a feature on the ChatBot that allows to send a data different than the answer. I know some webservices who want a 1 for Yes or 2 for No.

Nonetheless, Collect.Chat is an excellent tool, I adopt it :).